升级指南

RancherD 是一个实验性功能。

概述

当 RancherD 升级时,Rancher Helm controller 和 Fleet pod 都会升级。

在 RancherD 升级过程中,停机时间非常少,但 RKE2 有可能会停机一分钟,在此期间,您可能会失去对 Rancher 的访问。

当 Rancher 与 RancherD 一起安装时,底层的 Kubernetes 集群不能从 Rancher UI 中升级。它需要使用 RancherD CLI 进行升级。

升级 Rancher Helm Chart 而不升级底层集群

要在不升级底层 Kubernetes 集群的情况下升级 Rancher,请遵循以下步骤。

在升级之前,我们建议您应该。

  1. 用 Helm 卸载 Chart。

    helm uninstall rancher
  2. 用 Helm 重新安装 Rancher Chart。要安装特定的 Rancher 版本,使用--version标签。比如说

    helm install rancher rancher-latest/rancher\
    --namespace cattle-system
    --set hostname=rancher.my.org .
    --version 2.5.1

结果: Rancher 已升级到新版本。

如果需要,请按照这些步骤从备份中恢复 Rancher。

升级 Rancher 和底层集群

通过重新运行 RancherD 安装脚本,同时升级 RancherD 和底层 Kubernetes 集群。

在升级之前,我们建议您应该。

sudo curl -sfL https://get.rancher.io - sudo sh -

要指定一个特定的升级版本,使用INSTALL_RANCHERD_VERSION环境变量。

curl -sfL https://get.rancher.io | INSTALL_RANCHERD_VERSION=v2.5.1 sh -

然后启动服务器。

systemctl enable rancherd-server
systemctl start rancherd-server

也可以通过手动安装所需版本的二进制文件进行升级。

最后由 yzeng25更新 于